System Requirements

To properly access the agreements, forms and other information on Wealthfront, you will need a compatible operating system and web browser. The current fully supported configurations are listed below.

Browser Versions Operating System
Chrome 22.0 and above
Firefox 28.0 and above
Safari 6.1 and above
Internet Explorer 11.0 and above
Edge 12.0 and above